Etiquetas

, , ,

Argumentando pretextos técnicos, los desarrolladores de Firefox 57 han bloqueado el uso de complementos que están en uso desde hace tiempo, y en el mejor de los casos,  ofrecen reemplazarlos con versiones pagas. Esto sólo confirma, una vez más, que el mundo del Software Libre/Abierto también tiene sus contradicciones.

Este problema se me presentó tanto en Windows 7 como en Lubuntu 16.04.
Para resolverlo, opté por una solución simple y efectiva: hacer downgrade a Firefox 56.

En el caso de Windows 7, los pasos que seguí para resolver el problema fueron:

  1. Descargar el binario de la versión 56 correspondiente desde el repositorio Firefox ubicado en https://ftp.mozilla.org/pub/firefox/releases/.
  2. Descomprimirlo, obteniendo una carpeta de nombre “firefox”.
  3. Reemplazar la carpeta “firefox” de la versión instalada (57) con la que descargamos.
  4. Desconectar la máquina de la red.
  5. Ejecutar firefox y configurarlo para que no se actualice automáticamente.
  6. Conectar la máquina a la red.

En el caso de Lubuntu 16.04 los pasos fueron:

  1. Descargar el binario de la versión 56 correspondiente desde el repositorio Firefox ubicado en https://ftp.mozilla.org/pub/firefox/releases/.
  2. Descomprimirlo, obteniendo una carpeta de nombre “firefox”.
  3. Reemplazar la carpeta “firefox” de la versión instalada (57) con la que descargamos. En este caso (Lubuntu 16.04) estaba ubicada en /opt.
  4. Bloquear la versión de los paquetes Firefox (57) con Synaptic, para preservar la versión que ha quedado operativa (56) de futuras actualizaciones automáticas de software. (el bloqueo es una de las opciones del menu

De esta manera recuperé el uso de mis viejos complementos, en todos los casos.